Jisho

×
44df21eb528311478eda0b1f6a4b29a4
21 Replies ・ Started by nitzi at 2017-09-29 19:53:00 UTC ・ Last reply by nitzi at 2017-11-16 03:44:14 UTC

Draw feature in Chrome not working

For some reason, the Draw function of Jisho.org doesn't work on Chrome nor FireFox, but it does work on Microsoft Edge.
Can someone help me get it to work on Chrome please. (I prefer Chrome)

Thanks

2986330e38386f92fee4774b0c54ed66
Kimtaro Admin at 2017-10-07 00:22:58 UTC

What device and operating system and version of chrome are you using? It works for me in chrome on Mac OS X.

83653a964d1ebf1dff492aa188412614
jakobd2 at 2017-10-07 02:33:25 UTC

Considering the mentioning of Microsoft Edge, I'd guess they use a Windows 10 device.

2986330e38386f92fee4774b0c54ed66
Kimtaro Admin at 2017-10-12 22:00:33 UTC

Yeah, and it’s probably a tablet. I’ve gotten scattered reports about that combination before. So I’m adding this to that bug ticket.

44df21eb528311478eda0b1f6a4b29a4
nitzi at 2017-10-15 23:27:15 UTC

I use a Windows 10 PC (not a tablet), and it's "Version 61.0.3163.100 (Official Build) (64-bit)" (the latest version).

44df21eb528311478eda0b1f6a4b29a4
nitzi at 2017-10-15 23:33:17 UTC

Chrome is version 61 ⇈

2986330e38386f92fee4774b0c54ed66
Kimtaro Admin at 2017-10-15 23:31:57 UTC

@nitzi thank you for the details. I’ll try it out in an emulator and see if I can replicate the bug.

6ee23c5fa55b37168c3f360dded0acaa
Leebo at 2017-10-15 23:33:37 UTC

I've had times where the draw feature goes back and forth between working and not working, on PCs using Chrome. If it happens again, I'll try to document the specific situation, but hasn't been device dependent for me.

44df21eb528311478eda0b1f6a4b29a4
nitzi at 2017-10-19 01:29:36 UTC

any progress?

2986330e38386f92fee4774b0c54ed66
Kimtaro Admin at 2017-10-20 22:13:50 UTC

I just tried in Chrome 62 in Windows 10 and it was working fine.

@nitzi is it consistently not working? Do you have any extension installed? If so try disabling them and see if that fixes it.

44df21eb528311478eda0b1f6a4b29a4
nitzi at 2017-10-25 12:38:26 UTC

It's consistently not working :(
I disabled all my extensions and userscripts, and it still doesn't work.

2986330e38386f92fee4774b0c54ed66
Kimtaro Admin at 2017-11-05 19:27:10 UTC

@nitzi Do you use a mouse as the input device, or a tablet or something else?

22716fd689cc126ef5c542ff4506095f
Rumite at 2017-11-05 21:16:30 UTC

I have the same problem, but only in Chrome, it works in Firefox.
I'm using Chrome 62 and Firefox 56.0 on Ubuntu 16.04 LTS. I have a graphics tablet but I tried without it and same results.

2986330e38386f92fee4774b0c54ed66
Kimtaro Admin at 2017-11-05 23:07:29 UTC

Can you describe how it is behaving? Is it not returning any results, or is it returning a single result “f”?

2986330e38386f92fee4774b0c54ed66
Kimtaro Admin at 2017-11-05 23:24:47 UTC

I've dug into this a bit more and there seems to be something odd going on on the server side. I'll post again when I know more/have a fix.

22716fd689cc126ef5c542ff4506095f
Rumite at 2017-11-06 11:18:26 UTC

Sorry, I wasn't clear enough. The draw function actually works, but I can't see what I'm drawing.
https://i.imgur.com/dbOwuH0.mp4
I think that's from my end, but Jisho is the only website where I have this issue.

2ea591a11b65d06b9d3b5e76d6c9d9ed
dijek at 2017-11-07 02:08:10 UTC

I don't know how helpful it is, but on my Windows 10 laptop that has a touch-screen, in chrome, I can use my touchscreen but my mouse doesn't work. Also, sometimes I can't see the lines. I don't know why I couldn't use the mouse because I think the touch-screen just emulates it online.

2986330e38386f92fee4774b0c54ed66
Kimtaro Admin at 2017-11-07 20:04:52 UTC

@Rumite Ah, that is probably a different issue, one that I also haven't been able to replicate or fix yet.

@dijek That does help - I wonder if the drawing library we use doesn't support touch events properly on all platforms.

44df21eb528311478eda0b1f6a4b29a4
nitzi at 2017-11-07 20:21:21 UTC

I use a mouse

2986330e38386f92fee4774b0c54ed66
Kimtaro Admin at 2017-11-07 20:25:00 UTC

@nitzi In what way is it not working?

Is it showing kanji results, but no strokes when you draw?

Is it showing the strokes that you draw, but returns nothing at all?

Is it showing the strokes that you draw, but returns only "f" as the result?

44df21eb528311478eda0b1f6a4b29a4
nitzi at 2017-11-10 18:41:12 UTC

Throughout the video, I'm clicking and dragging (I don't know how to show clicks).
https://streamable.com/w2gg6

44df21eb528311478eda0b1f6a4b29a4
nitzi at 2017-11-16 03:44:14 UTC

@Kimtaro I posted a video ↑ showing what happens. I really want this to work. Please help 🙏

to reply.